Marantz/Denon Plugin Development

Questions and comments specific to a particular plugin should go here.
V_J
Experienced User
Posts: 237
Joined: Tue Mar 04, 2014 9:00 am

Re: Marantz/Denon Plugin Development

Post by V_J » Tue May 05, 2020 3:18 pm

I am still in the process of adding commands for my amplifier, but I will need to do some more modifications: I am putting more data in payload, as this facilitates passing whatever was recognized to the subsequent action. This may break compatibility with the current plugin though... When I have it, I will post it.

edit:
It looks like its is working. Biggest change is that I made a bigger payload: the payload in my case contains 3 fields:
  • the suffix without the data (so e.g. mainzone.volume, or mainzone.surroundmode)
  • the value as returned by the amplifier (for volume this would be a number, for surroundmode this would be a character)
  • the string representation of the status (for the volume this is the same as the value, for surroundmode this would be the name of the mode)
The reason I added this is because I could not find a good why to extract the suffix without the data, but this part allows me to trigger an action that posts to http. The status allows me to pass on in a single byte what the current status is (interesting for processing, in my case as Loxone does not work well with strings, single or double bytes to work with are much easier), and finally the string representation allows me to not have to double this data elsewhere. :)
Still checking if it all works...

Peter M
Posts: 46
Joined: Tue Jun 18, 2019 5:13 am

Re: Marantz/Denon Plugin Development

Post by Peter M » Fri May 15, 2020 12:03 am

V_J wrote:
Mon Apr 20, 2020 6:24 pm
Stupid question: Tone bass and tone treble, for which I even have buttons on the remote, don't work (also not from the remote). Could it be the Audyssey correction that is preventing adjustment using those?
I have a Marantz 7704 and have experienced the problem you describe with bass and treble controls. My Marantz was purchased as an ex demo and had previously been setup with Audyssey engaged. I have a professionally calibrated system and so I turned Audyssey off. I then found that the bass and treble controls would work for multi-channel inputs via HDMI but not for stereo inputs via SPDIF. Using Hercules to trap feedback it became obvious that Audyssey, even though it was switched off, was messing with the system somehow, so I did a full factory reset and the problem went away. It appears to be a firmware bug.

Cheers,
Peter

V_J
Experienced User
Posts: 237
Joined: Tue Mar 04, 2014 9:00 am

Re: Marantz/Denon Plugin Development

Post by V_J » Fri May 15, 2020 8:52 am

Thanks for the info!
It is not that important for me (I don't feel the need to have this quick bass/treble adjustment), but was puzzled. There are some other functions that should not work according to the manual, but do, and other that do not work even though they should. So I attributed it to that, but interesting to hear that it may be Audyssey related. Thanks!

V_J
Experienced User
Posts: 237
Joined: Tue Mar 04, 2014 9:00 am

Re: Marantz/Denon Plugin Development

Post by V_J » Fri Jun 12, 2020 8:48 am

I need to get back to this... the return-to-normality after covid gave me very little time for anything... If I remember I'll post my modified files this weekend. I have been integrated them and they appear to work. The events are no longer backward compatible, as I extended the payload to contain the returned code, a string of the status and an event category. All of these things made it easier for me to put connect it to Loxone (the code, as Loxone does not process strings well; the string as then I don't have to make this elsewhere and the same string is usable everywhere and the category, mainly for grouping things).

Post Reply