PushBullet plugin (Pako)

Questions and comments specific to a particular plugin should go here.
User avatar
Pako
Plugin Developer
Posts: 2280
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Tue Jul 04, 2017 4:41 am

piert wrote:I know it should be solved in 0.2.19, but it actually appears not to be since I am using 0.2.19 and the problem remains
I'm sorry, I already know the cause. It was necessary to add one more point to the instructions:
In the directory Eventhost\lib26\site-packges, the websocket subdirectory is located. It is necessary to remove it!

Pako
You know flattr ? You can Image

piert
Experienced User
Posts: 260
Joined: Tue Jun 14, 2011 2:53 pm

Re: PushBullet plugin (Pako)

Post by piert » Tue Jul 04, 2017 6:28 am

I tried the following:

1 Exit Eventghost
2 Delete the subfolder 'websocket' from the directory 'Eventhost\lib26\site-packges'
3 Restarted Eventghost

I get the following red text error in the event log and the start-up tree of Eventghost does not load at all (the panel to the right of the event log stays blank):

08:21:51 ---> Welcome to EventGhost <---
08:22:02 Error while loading plugin-file C:\Program Files\EventGhost\plugins\Webserver.
08:22:02 Traceback (most recent call last) (1710):
08:22:02 File "C:\Program Files\EventGhost\plugins\Webserver\__init__.py", line 153, in <module>
08:22:02 from websocket import WebSocketApp
08:22:02 ImportError: No module named websocket
08:22:02 Unhandled exception in WorkerThread <EventThread>:
08:22:02 Callers stack:
08:22:02 File "wx\_core.pyc", line 8010, in MainLoop
08:22:02 File "wx\_core.pyc", line 7306, in MainLoop
08:22:02 File "wx\_core.pyc", line 14669, in <lambda>
08:22:03 Traceback (most recent call last) (1710):
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\ThreadWorker.py", line 326, in __DoOneEvent
08:22:03 self.HandleAction(action)
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\ThreadWorker.py", line 289, in HandleAction
08:22:03 action()
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\ThreadWorker.py", line 62, in __call__
08:22:03 self.returnValue = self.func(*self.args, **self.kwargs)
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\EventThread.py", line 142, in StartSession
08:22:03 actionThread.Func(actionThread.StartSession, 120)(filename)
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\ThreadWorker.py", line 62, in __call__
08:22:03 self.returnValue = self.func(*self.args, **self.kwargs)
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\ActionThread.py", line 39, in StartSession
08:22:03 eg.document.Load(filename)
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\Document.py", line 145, in Load
08:22:03 root = self.RootItem(self, node)
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\RootItem.py", line 55, in __init__
08:22:03 ContainerItem.__init__(self, parent, node)
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\ContainerItem.py", line 38, in __init__
08:22:03 for childNode in node
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\AutostartItem.py", line 43, in __init__
08:22:03 child = self.document.PluginItem(self, childNode)
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\PluginItem.py", line 62, in __init__
08:22:03 self,
08:22:03 File "C:\Program Files\EventGhost\eg\Classes\PluginManager.py", line 138, in OpenPlugin
08:22:03 info = clsInfo.CreateInstance(args, evalName, treeItem)
08:22:03 AttributeError: 'NoneType' object has no attribute 'CreateInstance'

When looking at this, it makes sense. I am using the Webserver of Eventghost, which probably needs the websocket subfolder?

User avatar
Pako
Plugin Developer
Posts: 2280
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Tue Jul 04, 2017 5:44 pm

I have to apologize again.
Unfortunately, I did not realize, that any other plugin might need a websocket :oops: (and even I myself built a websocket support into the Webserver plugin :o ).
The solution is easy fortunately:
In the folder EventGhost\plugins\PushBullet\lib, the websocket subdirectory is located (this is a newer version).
Take this subdirectory and copy it to the EventGhost\lib26\site-packages folder. Then, restart EventGhost. That is all.

Pako
You know flattr ? You can Image

piert
Experienced User
Posts: 260
Joined: Tue Jun 14, 2011 2:53 pm

Re: PushBullet plugin (Pako)

Post by piert » Tue Jul 04, 2017 6:32 pm

Pako, with the amount of work you put into Eventghost and your plugins, you never have to apologize :D

I can confirm that the solution you provided now works well: there is no more red text and I can again send and receive Pushbullets. Thank you once again!

mlody11
Posts: 1
Joined: Tue Aug 29, 2017 5:12 pm

Re: PushBullet plugin (Pako)

Post by mlody11 » Tue Aug 29, 2017 5:16 pm

I've been trying to get this to work with 0.5-RC4 but it looks like its a no go. This would be an amazing plugin to utilize, any plans on porting it to 0.5? Anyone got it to work under 0.5?

koble73
Posts: 2
Joined: Sat Jul 08, 2017 6:04 am

Re: PushBullet plugin (Pako)

Post by koble73 » Fri Sep 01, 2017 4:28 am

Hello,

I had this plugin working not too long ago. However, recently I can not seem to event get pushbullet to recognize the eventghost plugin on my device list. When I link my account to the API in eventghost I get a "Pushbullet API Access" connected app in the pushbullet interface; however, no devices for the eventghost are showing up. I was wondering if this is a problem other people were having as well.

projazz
Posts: 5
Joined: Thu Sep 07, 2017 12:46 am

Re: PushBullet plugin (Pako)

Post by projazz » Thu Sep 07, 2017 1:23 am

koble73 wrote:Hello,

I had this plugin working not too long ago. However, recently I can not seem to event get pushbullet to recognize the eventghost plugin on my device list. When I link my account to the API in eventghost I get a "Pushbullet API Access" connected app in the pushbullet interface; however, no devices for the eventghost are showing up. I was wondering if this is a problem other people were having as well.
I too have this same problem. No devices for eventghost show up and when I try to push from Eventghost I receive "PushBullet: No connectivity, waiting ..." error.

User avatar
Pako
Plugin Developer
Posts: 2280
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Thu Sep 07, 2017 1:02 pm

I can not help when I have a lack of information.
For example:
What is the operating system?
What is the EventGhost version?
What is the PushBullet plugin version?
Are you using a proxy?
Desktop PB application and / or Chrome PB extension works smoothly?
It would also help if you attach a screenshot of the configuration dialog and detailed content of the EventGhost log (select logging level 5).
Note:
I can not provide support for EventGhost 0.5 currently.

Pako

projazz
Posts: 5
Joined: Thu Sep 07, 2017 12:46 am

Re: PushBullet plugin (Pako)

Post by projazz » Fri Sep 08, 2017 10:24 pm

Sorry for the initial lack of info.... please see below and thank you much in advance!

OS = Windows 10 Pro
EventGhost version = 0.4.1.r1722
PushBullet plugin version = 0.2.19
No proxy
Desktop PB application runs smoothly version = 396

Eventghost Log
17:17:10 ---> Welcome to EventGhost <---
17:17:10 Autostart
17:17:10 Plugin: X10: Generic X10
17:17:10 Plugin: Zoom Player
17:17:10 Plugin: Winamp
17:17:10 Plugin: Task Create/Switch Events
17:17:11 Enable exclusive: Keyboard Emulation
17:17:11 Plugin: auvisio VRC-1100 Ro
17:17:11 Plugin: PushBullet
17:17:11 Winamp.Status.Changed.Off
17:17:11 Main.OnInit
17:17:13 Task.Created.EventGhost
17:17:13 Task.NewWindow.EventGhost
17:17:13 Task.Activated.EventGhost
17:17:40 PushBullet: Push
17:17:40 PushBullet: No connectivity, waiting ...

The last entry in the log happens when clicking Test button on new macro for Push
Attachments
Configuration_Dialog.PNG

User avatar
Pako
Plugin Developer
Posts: 2280
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Mon Sep 11, 2017 3:42 pm

Pako wrote:... and detailed content of the EventGhost log (select logging level 5).
Please set logging level 5 and then attach the appropriate log.

Pako
You know flattr ? You can Image

akamiking
Posts: 7
Joined: Tue Sep 12, 2017 6:29 am

Re: PushBullet plugin (Pako)

Post by akamiking » Tue Sep 12, 2017 6:36 am

I am experiencing a similar "No connectivity" issue. This is a fresh install. Details below, and please let me know if more is needed:

OS = Windows 10 Pro
EventGhost version = 0.4.1.r1722
PushBullet plugin version = 0.2.19
No proxy
Desktop PB application runs smoothly version = 396
Logging enabled to 5

01:34:53 ---> Welcome to EventGhost <---
01:34:54 Autostart
01:34:54 Plugin: X10: Generic X10
01:34:54 Error starting plugin: X10 Remote
01:34:54 No X10 receiver found!
01:34:54 Plugin: Zoom Player
01:34:54 Plugin: Winamp
01:34:54 Plugin: Task Create/Switch Events
01:34:54 Enable exclusive: Keyboard Emulation
01:34:54 Plugin: PushBullet
01:34:54 Winamp.Status.Changed.Off
01:34:54 Main.OnInit
01:34:59 PushBullet: Push to everything: note to Everything
01:34:59 PushBullet: No connectivity, waiting ...
01:35:00 PushBullet: Push to everything: note to Everything
01:35:00 PushBullet: No connectivity, waiting ...
01:35:00 Task.Activated.EventGhost

Pushbullet does not show EG in Devices. I am also not able to edit any of the windows when adding a Macro.

Thanks in advance and please let me know what else is needed.

User avatar
Pako
Plugin Developer
Posts: 2280
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Tue Sep 12, 2017 7:58 am

Please use the diagnostic version.
This should make some extra log entries (as following, but the order of the messages may be different).

Code: Select all

09:42:49   ---> Welcome to EventGhost <---
09:42:53   ################ Diagnostic message 001 ################
09:42:53   ################ Diagnostic message 002 ################
09:42:53   ################ Diagnostic message 003 ################
09:42:53   ################ Diagnostic message 004 ################
09:42:53   ################ Diagnostic message 008 ################
09:42:53   ################ Diagnostic message 005 ################
09:42:53   ################ Diagnostic message 006 ################
09:42:53   ################ Diagnostic message 007 ################
09:42:53   ################ Diagnostic message 010 ################
09:42:53   PushBullet: Email address obtained
Pako
You know flattr ? You can Image

akamiking
Posts: 7
Joined: Tue Sep 12, 2017 6:29 am

Re: PushBullet plugin (Pako)

Post by akamiking » Tue Sep 12, 2017 3:06 pm

Pako wrote:Please use the diagnostic version.
This should make some extra log entries (as following, but the order of the messages may be different).
I replaced it with the diagnostic version and this is the full log when trying to Push to all devices:

10:04:55 ---> Welcome to EventGhost <---
10:04:55 Autostart
10:04:55 Plugin: X10: Generic X10
10:04:55 Error starting plugin: X10 Remote
10:04:55 No X10 receiver found!
10:04:55 Plugin: Zoom Player
10:04:55 Plugin: Winamp
10:04:55 Plugin: Task Create/Switch Events
10:04:55 Enable exclusive: Keyboard Emulation
10:04:55 Plugin: PushBullet
10:04:55 Winamp.Status.Changed.Off
10:04:55 Main.OnInit
10:04:57 ################ Diagnostic message 001 ################
10:04:57 ################ Diagnostic message 002 ################
10:04:57 ################ Diagnostic message 003 ################
10:04:57 ################ Diagnostic message 004 ################
10:04:57 ################ Diagnostic message 008 ################
10:04:58 ################ Diagnostic message 009 ################
10:05:03 ################ Diagnostic message 008 ################
10:05:03 ################ Diagnostic message 009 ################
10:05:08 ################ Diagnostic message 008 ################
10:05:08 ################ Diagnostic message 009 ################
10:05:12 PushBullet: Push to everything: note to Everything
10:05:12 PushBullet: No connectivity, waiting ...
10:05:13 ################ Diagnostic message 008 ################
10:05:13 ################ Diagnostic message 009 ################

projazz
Posts: 5
Joined: Thu Sep 07, 2017 12:46 am

Re: PushBullet plugin (Pako)

Post by projazz » Tue Sep 12, 2017 3:46 pm

Pako wrote:Please use the diagnostic version.
This should make some extra log entries (as following, but the order of the messages may be different).
With logging level 5 I see the same thing as akamiking

I ran the diagnotic version.

Code: Select all

10:22:40   ---> Welcome to EventGhost <---
10:22:40   EventGhost has found devices on your system, that can be 
10:22:40   handled by the following plugins and are not loaded by your
10:22:40   current configuration:
10:22:40      - auvisio VRC-1100 Ro
10:22:40   If you want to use them, please add the missing plugins.
10:22:40   Autostart
10:22:40      Plugin: PushBullet
10:22:40   Main.OnInit
10:22:42   ################ Diagnostic message 001 ################
10:22:42   ################ Diagnostic message 002 ################
10:22:42   ################ Diagnostic message 003 ################
10:22:42   ################ Diagnostic message 004 ################
10:22:42   ################ Diagnostic message 008 ################
10:22:42   ################ Diagnostic message 009 ################
10:22:47   ################ Diagnostic message 008 ################
10:22:47   ################ Diagnostic message 009 ################
10:22:52   ################ Diagnostic message 008 ################
10:22:52   ################ Diagnostic message 009 ################
10:22:57   ################ Diagnostic message 008 ################
10:22:58   ################ Diagnostic message 009 ################
10:23:03   ################ Diagnostic message 008 ################
10:23:03   ################ Diagnostic message 009 ################
10:23:08   ################ Diagnostic message 008 ################
10:23:08   ################ Diagnostic message 009 ################
10:23:09   System.RemoteConnect [u'']
10:23:13   ################ Diagnostic message 008 ################
10:23:13   ################ Diagnostic message 009 ################
10:23:18   ################ Diagnostic message 008 ################
10:23:18   ################ Diagnostic message 009 ################
10:23:23   ################ Diagnostic message 008 ################
10:23:23   ################ Diagnostic message 009 ################
10:23:28   ################ Diagnostic message 008 ################
10:23:28   ################ Diagnostic message 009 ################
10:23:30   System.RemoteDisconnect [u'']
10:23:33   ################ Diagnostic message 008 ################
10:23:33   ################ Diagnostic message 009 ################
Then just repeats 008 009 forever.

User avatar
Pako
Plugin Developer
Posts: 2280
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Tue Sep 12, 2017 5:12 pm

Finally, we get a little further.
Please use another diagnostic version.

Pako
You know flattr ? You can Image

Post Reply