E-mail

Questions and comments specific to a particular plugin should go here.
VADIM
Posts: 4
Joined: Wed Dec 11, 2013 11:49 am

E-mail

Post by VADIM » Wed Dec 11, 2013 11:58 am

Hello

I am trying to activate E-mail plugin with Gmail but get this error

SMTP Protocol Error: Cannot connect to SMTP server "smpt.gmail.com:465"

1. My FireWall disabled ,
2. i tried port 25 instead of 465
3.I tried connect with Telnet and it looks connected.


Please help

User avatar
Pako
Plugin Developer
Posts: 2290
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: E-mail

Post by Pako » Wed Dec 11, 2013 12:38 pm

I opened a new file in EventGhost, I added E-mail plugin and I configured it as follows:
Gmail001.png
Gmail002.png
It worked on the first try.
I think that the problem must be elsewhere than in EventGhost or plugin.

Pako

VADIM
Posts: 4
Joined: Wed Dec 11, 2013 11:49 am

Re: E-mail

Post by VADIM » Wed Dec 11, 2013 2:50 pm

Hi Pako

Thank for answer .

May be you can send me plugin " E-mail " you are using .

I also see that you using IMAP instead of POP.

Thanks Vadim

User avatar
Pako
Plugin Developer
Posts: 2290
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: E-mail

Post by Pako » Wed Dec 11, 2013 3:27 pm

VADIM wrote:Hi Pako
Thank for answer .
May be you can send me plugin " E-mail " you are using.
I use the last version that was published here (post from 2013 4 24 Wed, 09:37).
VADIM wrote:I also see that you using IMAP instead of POP.
Yes, I prefer to use IMAP if possible.

Pako

VADIM
Posts: 4
Joined: Wed Dec 11, 2013 11:49 am

Re: E-mail

Post by VADIM » Wed Dec 11, 2013 4:43 pm

Hi Pako

I tried the newest plugin , but without the success.

My be problem in my Email Action configuration , can you please send me example .

Many thanks Vadim

User avatar
Pako
Plugin Developer
Posts: 2290
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: E-mail

Post by Pako » Wed Dec 11, 2013 5:00 pm

VADIM wrote:My be problem in my Email Action configuration , can you please send me example.
I highly doubt it.
However - here is an example of an action that sends an e-mail.

Pako
Attachments
Gmail003.png

VADIM
Posts: 4
Joined: Wed Dec 11, 2013 11:49 am

Re: E-mail

Post by VADIM » Wed Dec 11, 2013 7:37 pm

Hi Pako

You are right the problem in the other place , the last i think is maybe my gmail account configurations .

If you know something about the requirements please tell me .

I am working with Eventghost tcp from/to my own Home Automation system , some plugins working very well but some require a lot of tuning .

Any way many many thanks and Best Regards .

dacari
Posts: 10
Joined: Sun Feb 02, 2014 2:52 am

Re: E-mail

Post by dacari » Sun Feb 02, 2014 3:06 am

Hello All,

can anyone advise if this plugin is working??..I have downloaded it from the link and added it. I have read through all the posts and but can not get it working. I install and configure using imap for gmail, when I try to setup a send email action, the "ok" box is always not clickable although I filled in all required fields. This is also the case for start observation...thanks for any help that can be offered.

User avatar
Pako
Plugin Developer
Posts: 2290
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: E-mail

Post by Pako » Sat Feb 08, 2014 9:46 am

dacari wrote:when I try to setup a send email action, the "ok" box is always not clickable although I filled in all required fields
This means that you have it configured incorrectly.
But we do not know why.
You can put screenshot?

Pako

dacari
Posts: 10
Joined: Sun Feb 02, 2014 2:52 am

Re: E-mail

Post by dacari » Sun Feb 09, 2014 3:50 am

Screencaps:
Screenshot 2014-02-08 22.41.41.png
Screenshot 2014-02-08 22.15.55.png
Screenshot 2014-02-08 22.28.12.png


Thanks for the help

User avatar
Pako
Plugin Developer
Posts: 2290
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: E-mail

Post by Pako » Sun Feb 09, 2014 6:55 am

You have filled recipient's name, but the address is empty.
Pako
Attachments
e-mail_send.png

dacari
Posts: 10
Joined: Sun Feb 02, 2014 2:52 am

Re: E-mail

Post by dacari » Sun Feb 09, 2014 2:32 pm

AAhhh...silly me!!..it works!!..thank you very much

wuffzack
Posts: 3
Joined: Wed May 23, 2012 3:29 pm

Re: E-mail

Post by wuffzack » Sat Aug 23, 2014 1:19 pm

Dear Pako,

I found a bug in your E-Mail plugin. Sending to multiple recipients doesn't work, because you pass the recipients as a string with comma delimited items, but smtp.sendmail expects a python list.

Instead of writing

Code: Select all

                if Copy is None:
                    smtp.sendmail(account[3], To, msg.as_string())
you can change it to

Code: Select all

                if Copy is None:
                    rcpnt = To.split(',')
                    smtp.sendmail(account[3], rcpnt, msg.as_string())
Same is true for the "else" case (which I can't test, I have no idea, when this code is reached).

Thank you!

User avatar
Pako
Plugin Developer
Posts: 2290
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: E-mail

Post by Pako » Sat Aug 23, 2014 1:41 pm

wuffzack wrote:I found a bug in your E-Mail plugin.
There is certainly a lot of bugs.
I made ​​this plugin a long time ago and my Python skills were very weak.
I thank you for reporting.

Pako

shaggy79
Experienced User
Posts: 129
Joined: Sun Jul 13, 2014 4:57 pm

Re: E-mail

Post by shaggy79 » Thu Jan 28, 2016 8:24 pm

Hi all,
Can anyone tell me what I am doing wrong as I cant seem to send Emails :?:
I get this Error:-
SMTP Protocol Error: Your message may not have been sent!

I am trying to get it to work with my gmail account :oops:

Thanks
Paul.

Post Reply