Save Changes: "Error! (backup)"

Support for the O-MEGA Project plugin
Post Reply
User avatar
Geek2theBone
Posts: 9
Joined: Wed Sep 18, 2019 2:52 pm

Save Changes: "Error! (backup)"

Post by Geek2theBone » Mon Aug 09, 2021 5:45 pm

I just this morning discovered O-MEGA and see so much potential for it being my new favorite use for Eventghost.

I've followed the setup instructions and twice through the "How to create a button" tutorial. After creating the first page/buttons and testing all fine over my network with TCP events, the save fails. I just get "Error! (backup)".

The "Quick Save" will also give this error. My Eventghost log has this for each occurrence:

Code: Select all

O-MEGA: Web-request failed - method: makeBackup args: [] kwargs: {}
Traceback (most recent call last):
  File "C:\ProgramData\EventGhost\plugins\O-MEGA\__init__.py", line 3142, in ExecuteWebFunction
    result = self.registeredWebFunctions[methodName](*args, **kwargs)
  File "C:\ProgramData\EventGhost\plugins\O-MEGA\__init__.py", line 1770, in makeBackup
    return omegalib.makeBackup()
  File "C:\ProgramData\EventGhost\plugins\O-MEGA\omegalib.py", line 128, in makeBackup
    shutil.copyfile(getSchedulghostXml(), backupsrc+"\\SG.xml")
  File "shutil.pyc", line 82, in copyfile
IOError: [Errno 2] No such file or directory: u'\\SchedulGhost.xml'
I would be very grateful for any guidance or troubleshooting assistance.

User avatar
Sem;colon
Plugin Developer
Posts: 895
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: Save Changes: "Error! (backup)"

Post by Sem;colon » Mon Aug 09, 2021 7:19 pm

Hello Geek2theBone!

I'm happy to read you like it :D

Now to your error: As the error message briefly indicates, there is a problem with creating the backup before saving your changes.
The stack trace in the log (thanks for that btw.) tells you it can't locate your SchedulGhost.xml file.

Can you check the location of the .XML file you specified in your SchedulGhost plugin configuration. Looks like there's something wrong with that ;)
If you like my work, Image me a drink :wink:

User avatar
Sem;colon
Plugin Developer
Posts: 895
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: Save Changes: "Error! (backup)"

Post by Sem;colon » Mon Aug 09, 2021 9:36 pm

... In Case you can't figure out how to fix the SchedulGhost.xml you can also recover the latest backup. But you would lose your changes in your EventGhost and O-MEGA configuration (everything after the backup has been created)
A backup is always created when you change something in the O-MEGA configuration.
If you like my work, Image me a drink :wink:

User avatar
Geek2theBone
Posts: 9
Joined: Wed Sep 18, 2019 2:52 pm

Re: Save Changes: "Error! (backup)"

Post by Geek2theBone » Tue Aug 10, 2021 6:02 pm

Alright - I'm not getting the error for saving anymore.

I had SchedulGhost first in my Autostart, but I didn't have it configured on this new server yet. I pointed it at a backup folder and then I re-ran the O-MEGA installer. Thanks!

I did however get an exception in the log, seeing if that's a port/firewall thing now/this evening.

Code: Select all

Exception happened during processing of request from ('::1', 61043, 0, 0)
Traceback (most recent call last):
  File "SocketServer.pyc", line 596, in process_request_thread
  File "SocketServer.pyc", line 331, in finish_request
  File "SocketServer.pyc", line 654, in __init__
  File "SocketServer.pyc", line 713, in finish
  File "socket.pyc", line 283, in close
  File "socket.pyc", line 307, in flush
error: [Errno 10053] An established connection was aborted by the software in your host machine

User avatar
Sem;colon
Plugin Developer
Posts: 895
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: Save Changes: "Error! (backup)"

Post by Sem;colon » Tue Aug 10, 2021 9:30 pm

Happy to hear that! :)

Yes, could be your firewall.. did you make sure the port(s) you setup in the O-MEGA plugin (or simply as application Eventghost) is not blocked by the windows firewall (inbound connection)?
If you like my work, Image me a drink :wink:

User avatar
Geek2theBone
Posts: 9
Joined: Wed Sep 18, 2019 2:52 pm

Re: Save Changes: "Error! (backup)"

Post by Geek2theBone » Wed Aug 11, 2021 4:30 pm

Windows Firewall has full incoming/outgoing allowances for Eventghost. I've not tried accessing from outside my local network, only localhost + port, so I don't think it is router/port-forwarding, right?

I'll double-check everything after work tonight. Thanks again.

User avatar
Sem;colon
Plugin Developer
Posts: 895
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: Save Changes: "Error! (backup)"

Post by Sem;colon » Wed Aug 11, 2021 6:48 pm

Hmm, should be fine then.. maybe there's also something else on your system; like a 3rd party antivirus or firewall.. or there's simply another program using the same ports.
You can try changing the ports in the O-MEGA plugin configuration and see if the error persists ;)
If you like my work, Image me a drink :wink:

User avatar
Geek2theBone
Posts: 9
Joined: Wed Sep 18, 2019 2:52 pm

Re: Save Changes: "Error! (backup)"

Post by Geek2theBone » Thu Aug 12, 2021 6:33 pm

I have tried:
  • Changing ports
  • Different Browsers accessing localhost
  • Incognito Browsers accessing localhost
  • Deleted/redo firewall for eventghost and specific ports
  • Watched logs from Windows and CurrPorts
  • netstat commands to find PID (no conflicts)
I dunno, man. I'll try to circle back to this over the weekend if I can find time.
Thanks for your time on this so far.

User avatar
Sem;colon
Plugin Developer
Posts: 895
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: Save Changes: "Error! (backup)"

Post by Sem;colon » Thu Aug 12, 2021 8:23 pm

Oh, sorry mate..
I just noticed this is the "normal" error message ^^°
I'm ignoring it for so long that I totally forgot about it, haha

O-MEGA is using long-polling technique to present always up to date values. For that to happen, I request is sent to the server and "waits there" until something changes and then returns to the web interface.
When you close your browser (as example), this causes the request to be aborted, resulting in that error.

I didn't figure out how to silence it, but you can safely ignore that one, it doesn't have a negative impact ;)
Sorry again for not identifying this in the first place
If you like my work, Image me a drink :wink:

User avatar
Sem;colon
Plugin Developer
Posts: 895
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: Save Changes: "Error! (backup)"

Post by Sem;colon » Mon Oct 18, 2021 8:23 pm

Btw. The latest release also fixed the issue with "quick save", that most likely destroyed your config in the first place. (Happened when you used "quick save" two times in a row within 3 seconds)
If you like my work, Image me a drink :wink:

Post Reply