Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Found a bug in EventGhost? Report it here.
User avatar
kgschlosser
Site Admin
Posts: 5498
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by kgschlosser » Sat Aug 03, 2019 12:15 pm

http://www.eventghost.net/#download

you want to try
Win USB Addon or the USB Remote
If you like the work I have been doing then feel free to Image

alex_m
Posts: 6
Joined: Sat Aug 03, 2019 10:39 pm

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by alex_m » Mon Aug 05, 2019 8:15 am

Zeoch and Tschutscha, have you solved the problem with intsllation of Auvisio Driver?

Tschutscha
Posts: 4
Joined: Mon Jul 29, 2019 1:43 pm

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by Tschutscha » Tue Aug 06, 2019 4:38 am

I have both packages installed. Unfortunately, there is no auvisio driver here.

User avatar
kgschlosser
Site Admin
Posts: 5498
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by kgschlosser » Tue Aug 06, 2019 6:16 am

I want to verify that you have driver signing disabled. this post tells you how to do it without putting windows into a test mode.

viewtopic.php?p=45688#p45688

I am going to put together a driver package specifically for this remote and see if you can install it manually through device manager.
Give me a few I am going to hammer it out right now.
If you like the work I have been doing then feel free to Image

User avatar
kgschlosser
Site Admin
Posts: 5498
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by kgschlosser » Tue Aug 06, 2019 6:31 am

I believe I found part of the problem.

If you go to C:\Program Files (x86)\EventGhost you will see a folder in there called drivers.

I want you to copy that folder.

Then in the address bar type in %programdata%\EventGhost and press enter.
Then paste the folder there.

Then install the plugin and it should be able to locate the files now and build the inf file properly. If it still does not work let me know I have already manually built the inf file and I will upload it if needed.
If you like the work I have been doing then feel free to Image

User avatar
kgschlosser
Site Admin
Posts: 5498
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by kgschlosser » Tue Aug 06, 2019 6:36 am

you can also try this as well.

with a decent text editor like sublime text or notepad++ DO NOT USE Notepad WordPad included with Windows
open the file C:\Program Files (x86)\EventGhost\eg\Classes\WinUsb.py

on line 88 you will see

Code: Select all

DOWNLOAD_ROOT = "http://www.eventghost.org/downloads/winusb/%s/" % PLATFORM
change it to

Code: Select all

DOWNLOAD_ROOT = "http://www.eventghost.net/downloads/winusb/%s/" % PLATFORM
that should also fix the issue as well.
If you like the work I have been doing then feel free to Image

alex_m
Posts: 6
Joined: Sat Aug 03, 2019 10:39 pm

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by alex_m » Tue Aug 06, 2019 12:14 pm

kgschlosser wrote:
Tue Aug 06, 2019 6:31 am
I believe I found part of the problem.

If you go to C:\Program Files (x86)\EventGhost you will see a folder in there called drivers.

I want you to copy that folder.

Then in the address bar type in %programdata%\EventGhost and press enter.
Then paste the folder there.

Then install the plugin and it should be able to locate the files now and build the inf file properly. If it still does not work let me know I have already manually built the inf file and I will upload it if needed.
SOLVED!!! :D
Thank you so much!

Tschutscha
Posts: 4
Joined: Mon Jul 29, 2019 1:43 pm

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by Tschutscha » Tue Aug 06, 2019 4:36 pm

This solution also worked for me.

Thanks for your support.

Regards

User avatar
kgschlosser
Site Admin
Posts: 5498
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by kgschlosser » Tue Aug 06, 2019 9:50 pm

sorry it took me a while to track down the issue. I am glad to have solved it for you. I will be making a code change to the core of EG to fix this issue.
If you like the work I have been doing then feel free to Image

Zeoch
Posts: 4
Joined: Wed Sep 06, 2017 7:55 pm

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by Zeoch » Sat Aug 10, 2019 9:40 am

kgschlosser wrote:
Tue Aug 06, 2019 6:31 am
I believe I found part of the problem.

If you go to C:\Program Files (x86)\EventGhost you will see a folder in there called drivers.

I want you to copy that folder.

Then in the address bar type in %programdata%\EventGhost and press enter.
Then paste the folder there.

Then install the plugin and it should be able to locate the files now and build the inf file properly. If it still does not work let me know I have already manually built the inf file and I will upload it if needed.
This works for me too.
Thank you very much ! :=)

nesspj
Posts: 1
Joined: Thu Feb 13, 2020 11:40 am

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by nesspj » Thu Feb 13, 2020 11:53 am

Zeoch wrote:
Sat Aug 10, 2019 9:40 am
kgschlosser wrote:
Tue Aug 06, 2019 6:31 am
I believe I found part of the problem.

If you go to C:\Program Files (x86)\EventGhost you will see a folder in there called drivers.

I want you to copy that folder.

Then in the address bar type in %programdata%\EventGhost and press enter.
Then paste the folder there.

Then install the plugin and it should be able to locate the files now and build the inf file properly. If it still does not work let me know I have already manually built the inf file and I will upload it if needed.
This works for me too.
Thank you very much ! :=)
@kgschlosser: Can you confirm this 'fix' should already be in the most recent build?
I recently created another PC to use as a HTPC accompanied by a VRC-1100 remote.
I tried all plugins (MCE Remote, MCE Remote Win7, Generic HID plugin) and none of them seem to capture my VRC-1100 input anymore!
- Yes, i have Driver signature enforcement disabled
- I ran EG in Administrator mode when adding the MCE Remote plugin and restarted the PC twice, as suggested.
Would the above solution fix my issue as well?

User avatar
kgschlosser
Site Admin
Posts: 5498
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by kgschlosser » Thu Feb 13, 2020 11:11 pm

yes the above fix will solve your problem.
This issue has not been addressed as of yet. the "fix" i posted is more of a workaround for the time being until I get the time to correct the underlying problem. and that is going to be corrected when the plugin repository I have been working on comes online in the no so distant future.
If you like the work I have been doing then feel free to Image

jrockow
Posts: 10
Joined: Fri Nov 15, 2013 12:26 pm

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by jrockow » Sun Feb 23, 2020 8:06 pm

I just came across this thread and hope I can get some help.
Been running EventGhost on WIN 7 without any problem.
Recently I've upgraded to WIN 10.
Whenever I try to download the plugin I get an error:

Exception in thread Thread-5:Traceback (most recent call last):
File "threading.pyc", line 532, in __bootstrap_inner
File "threading.pyc", line 484, in run
File "C:\Program Files (x86)\EventGhost\eg\Classes\TransferDialog.py", line 261, in ThreadRun
todo = self.CreateActions()
File "C:\Program Files (x86)\EventGhost\eg\Classes\TransferDialog.py", line 249, in CreateActions
size = self.HttpGetSize(src)
File "C:\Program Files (x86)\EventGhost\eg\Classes\TransferDialog.py", line 307, in HttpGetSize
testFile = urllib2.urlopen(path)
File "urllib2.pyc", line 126, in urlopen
File "urllib2.pyc", line 397, in open
File "urllib2.pyc", line 510, in http_response
File "urllib2.pyc", line 435, in error
File "urllib2.pyc", line 369, in _call_chain
File "urllib2.pyc", line 518, in http_error_default
HTTPError: HTTP Error 404: Not Found

I believe I have the driver sig thing turned off.
How would I know for sure?

I looked at the "winusb.py" and it was already changed to ".Net".
Also, for what it's worth, I don't have a "drivers" folder in any directory.

Please help.

jrockow
Posts: 10
Joined: Fri Nov 15, 2013 12:26 pm

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by jrockow » Tue Feb 25, 2020 1:44 am

Today I downloaded the latest version (for WIN 10) of EventGhost, disabled the signature checking, and was able to download the driver.
Thanx!

jrockow
Posts: 10
Joined: Fri Nov 15, 2013 12:26 pm

Re: Solved: Auvisio VRC-1100 stopped working after Win 10 update 1607

Post by jrockow » Thu Feb 27, 2020 7:17 pm

UPDATE! UPDATE!

I don't know how I ever got it to work that one time, but I've tried numerous times since then, with different PCs and I can't get it installed.
I'm back to the original problem that I posted.
This really stinks; I have wasted so much time on this one problem.
I wish someone could help.

Post Reply