[Windows 10] EG won't open last saved XML file after reboot.

Found a bug in EventGhost? Report it here.
Post Reply
copota
Posts: 33
Joined: Sat Mar 27, 2010 4:08 pm

[Windows 10] EG won't open last saved XML file after reboot.

Post by copota » Wed Aug 05, 2015 7:17 pm

I'm on Windows 10 RTM. I have EG version 0.4.1.r1700 (latest build) installed.

The XML file I use for my default EG configuration is saved in the "My Documents" folder on my SSD. When I reboot my PC, EG will not open my saved XML configuration file. Instead, EG reverts to opening the "Example.xml" configuration located in the EG application folder.

I tested this on my main PC and a virtual machine both using Windows 10. Each had the same result.

The only workaround I have for now, is to save my custom configuration as "Example.xml" and copy into my EG's install folder. However, that will only work as a read only solution, not allowing me to save any changes.

Can anyone using Windows 10 confirm this is an actual bug, as I'm unsure if it's simply due to my personal configuration.

m19brandon
Experienced User
Posts: 177
Joined: Mon Feb 03, 2014 10:36 pm

Re: [Windows 10] EG won't open last saved XML file after reb

Post by m19brandon » Sat Aug 08, 2015 5:16 am

I am on Windows 10 and do not have that issue.

Try running EG with the "Run as administrator" option and selecting your xml file. I think this path is in reg somewhere and this should update that value. Then exit and retry as your normally would.

copota
Posts: 33
Joined: Sat Mar 27, 2010 4:08 pm

Re: [Windows 10] EG won't open last saved XML file after reb

Post by copota » Sat Aug 08, 2015 7:37 am

Thanks for the response.

I actually have EG set to run as administrator with a task I created in task scheduler. The scheduled task starts EG at log on of user, and starts it with administrator privileges.

I'm still experiencing the problem. Sometimes it will load my file on reboot, most times it wont.

I have been getting an error reported by windows when rebooting. Windows reports upon reboot that Eventghost Message Receiver is preventing a restart. Then it will eventually reboot. Here's a screenshot of the error I get upon reboot or shutting down...

Image



I'm wondering if it might be a plugin that's crashing EG upon reboot. Here's a link of my EG configuration page showing all my plugins I have activated...

Image

Sem;colon
Experienced User
Posts: 609
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: [Windows 10] EG won't open last saved XML file after reb

Post by Sem;colon » Sat Aug 08, 2015 8:33 am

Well you should remove the "unknown plugin" anyhow.
But I don't think this will resolve the issue.

As a workaround you can pass the path to your XML as parameter in your schedule

copota
Posts: 33
Joined: Sat Mar 27, 2010 4:08 pm

Re: [Windows 10] EG won't open last saved XML file after reb

Post by copota » Sat Aug 08, 2015 1:57 pm

Sem;colon wrote:As a workaround you can pass the path to your XML as parameter in your schedule
Thanks! Good idea for a workaround. Just tried it out and so far, working well.

I posted a screenshot of how I have the Actions page configured for my scheduled task, in case anyone wants to do the same.

Image

KeyX
Posts: 1
Joined: Mon Aug 13, 2018 4:42 pm

Re: [Windows 10] EG won't open last saved XML file after reb

Post by KeyX » Mon Aug 13, 2018 4:48 pm

"I posted a screenshot of how I have the Actions page configured for my scheduled task, in case anyone wants to do the same."

Where can i open this Window? Is it in Eventghost or in Windows itself?

Post Reply