[FIXED] Bug at the first installation EG to computer

Found a bug in EventGhost? Report it here.
Post Reply
User avatar
Pako
Plugin Developer
Posts: 2294
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

[FIXED] Bug at the first installation EG to computer

Post by Pako » Mon Nov 12, 2007 11:42 am

If in computer have not yet been EG:
A)
1. install EventGhost_0.3.6_build_1141_Setup.exe and NOT Start/Launch
2. install EventGhost_0.3.6_build_1154_Update.exe and Start -> error message to notepad:

Code: Select all

Traceback (most recent call last):
  File "EventGhost.pyw", line 34, in <module>
  File "d:\Programs\E\EventGhost\eg\Main.py", line 131, in <module>
    eg = Init.EventGhost(args)
  File "d:\Programs\E\EventGhost\eg\Init.py", line 135, in __init__
    self.config = config = LoadConfig()
  File "d:\Programs\E\EventGhost\eg\ConfigData.py", line 73, in LoadConfig
    config = Persistent.PyLoad(configFilePath, DefaultConfig)
  File "d:\Programs\E\EventGhost\eg\Persistent.py", line 114, in PyLoad
    eg.DebugNote('File "%s" does not exist.' % filename)
  File "d:\Programs\E\EventGhost\eg\Init.py", line 263, in __getattr__
    mod = __import__("Dialogs.%s" % name, fromlist=[name])
ImportError: No module named DebugNote
B)
1. install EventGhost_0.3.6_build_1141_Setup.exe and Start/Launch
2. install EventGhost_0.3.6_build_1154_Update.exe and Start -> work properly
Pako

User avatar
Bitmonster
Site Admin
Posts: 2239
Joined: Mon Feb 06, 2006 10:28 pm

Re: Bug at the first installation EG to computer

Post by Bitmonster » Mon Nov 12, 2007 1:43 pm

=> 0.3.6.1158
Please post software-related questions in the forum - PMs will only be answered, if really private, thanks!

User avatar
Pako
Plugin Developer
Posts: 2294
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: Bug at the first installation EG to computer

Post by Pako » Wed Nov 14, 2007 3:47 pm

Fixed !

Post Reply