[FIXED] -translate not works

Found a bug in EventGhost? Report it here.
Post Reply
User avatar
Pako
Plugin Developer
Posts: 2294
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

[FIXED] -translate not works

Post by Pako » Thu Apr 26, 2007 2:33 pm

Release: 0.3.6.954
-translate commandline option only created log file (without -debug option):
Traceback (most recent call last):
File "EventGhost.pyw", line 33, in <module>
File "d:\Programs\E\EventGhost/eg/Main.py", line 130, in <module>
e = win32com.client.Dispatch("{7EB106DC-468D-4345-9CFE-B0021039114B}")
File "win32com\client\__init__.pyc", line 95, in Dispatch
File "win32com\client\dynamic.pyc", line 98, in _GetGoodDispatchAndUserName
File "win32com\client\dynamic.pyc", line 78, in _GetGoodDispatch
pywintypes.com_error: (-2147023174, 'Server RPC nen\xed k\xa0dispozici.', None, None)
Traceback (most recent call last):
File "EventGhost.pyw", line 34, in <module>
File "d:\Programs\E\EventGhost/eg/Main.py", line 114, in <module>
LanguageEditor.Start(args)
File "d:\Programs\E\EventGhost\eg\LanguageEditor.py", line 40, in Start
LanguageEditor(None)
File "d:\Programs\E\EventGhost\eg\LanguageEditor.py", line 258, in __init__
self.LoadLanguage(self.config.language)
File "d:\Programs\E\EventGhost\eg\LanguageEditor.py", line 344, in LoadLanguage
self.FillTree(newId, value, evalPath)
File "d:\Programs\E\EventGhost\eg\LanguageEditor.py", line 481, in FillTree
value = node.__class__.__dict__[key]
KeyError: 'description'

User avatar
Bitmonster
Site Admin
Posts: 2239
Joined: Mon Feb 06, 2006 10:28 pm

Post by Bitmonster » Thu Apr 26, 2007 3:06 pm

958 should fix this...
Please post software-related questions in the forum - PMs will only be answered, if really private, thanks!

User avatar
Pako
Plugin Developer
Posts: 2294
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Post by Pako » Thu Apr 26, 2007 6:12 pm

Unfortunately only slight difference...
Traceback (most recent call last):
File "EventGhost.pyw", line 34, in <module>
imp.load_source("Main", path + "/eg/Main.py")
File "D:\Programs\E\EventGhost/eg/Main.py", line 114, in <module>
LanguageEditor.Start(args)
File "D:\Programs\E\EventGhost\eg\LanguageEditor.py", line 40, in Start
LanguageEditor(None)
File "D:\Programs\E\EventGhost\eg\LanguageEditor.py", line 184, in __init__
OpenPlugin(plugin, plugin, ())
File "D:\Programs\E\EventGhost\eg\PluginTools.py", line 328, in OpenPlugin
plugin = info.CreatePluginInstance(evalName, treeItem)
File "D:\Programs\E\EventGhost\eg\PluginTools.py", line 211, in CreatePluginInstance
eg.PrintTraceback()
File "D:\Programs\E\EventGhost\eg\Init.py", line 551, in PrintTraceback
eg.PrintError(error.rstrip())
File "D:\Programs\E\EventGhost\eg\Init.py", line 533, in PrintError
self.log.DoPrint(text, 1)
File "D:\Programs\E\EventGhost\eg\Init.py", line 285, in __getattr__
raise AttributeError
AttributeError

User avatar
Bitmonster
Site Admin
Posts: 2239
Joined: Mon Feb 06, 2006 10:28 pm

Post by Bitmonster » Thu Apr 26, 2007 6:18 pm

Hmm, the error looks like some plugin is crashing on load. Possibly an old plugin that is no longer in the distribution but stays in your plugin folder. Please try to delete the complete EventGhost folder in your "program files" directory and reinstall EG.
Please post software-related questions in the forum - PMs will only be answered, if really private, thanks!

User avatar
Pako
Plugin Developer
Posts: 2294
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Post by Pako » Thu Apr 26, 2007 7:26 pm

Was it really that way. Now works it properly.
Thanks for your help !

Post Reply