erros when loading egtree made in stable version

Found a bug in EventGhost? Report it here.
Post Reply
Tiddu
Posts: 6
Joined: Sat Nov 30, 2019 7:04 am

erros when loading egtree made in stable version

Post by Tiddu » Mon Feb 17, 2020 11:25 am

i have w10 installed and saw in main page that pre release version is recommended for it. So , i uninstalled the stable one and installed the pre release rc6 one and loaded my egtree made in the stable one

Image

after removing duplicate lines and sorting , these are the unique values
(("*" in key or "?" in key) and fnmatchcase(eventString, key))
action()
actionThread.Func(actionThread.StartSession, 120)(filename)
eg.PrintTraceback()
event.Execute()
event.SetShouldEnd()
self.HandleAction(action)
self.__DoOneEvent()
self.returnValue = self.func(*self.args, **self.kwargs)

File "C:\Program Files (x86)\EventGhost\eg\Classes\ActionThread.py", line 119, in StartSession
File "C:\Program Files (x86)\EventGhost\eg\Classes\ActionThread.py", line 43, in HandleAction
File "C:\Program Files (x86)\EventGhost\eg\Classes\EventGhostEvent.py", line 124, in Execute
File "C:\Program Files (x86)\EventGhost\eg\Classes\EventThread.py", line 138, in Execute
File "C:\Program Files (x86)\EventGhost\eg\Classes\EventThread.py", line 144, in Transfer
File "C:\Program Files (x86)\EventGhost\eg\Classes\EventThread.py", line 75, in StartSession
File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 140, in HandleAction
File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 253, in __DoOneEvent
File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 269, in __DoOneEvent
File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 280, in __MainLoop
File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 324, in __call__

File "fnmatch.pyc", line 82, in fnmatchcase
File "re.pyc", line 194, in compile
File "re.pyc", line 251, in _compile
File "threading.pyc", line 754, in run
File "threading.pyc", line 774, in __bootstrap
File "threading.pyc", line 801, in __bootstrap_inner
File "wx\_core.pyc", line 16766, in <lambda>
File "wx\_core.pyc", line 7952, in MainLoop
File "wx\_core.pyc", line 8657, in MainLoop

---> Welcome to EventGhost <---
Callers stack:
Traceback (most recent call last) (0.5.0-rc6):
Unhandled exception in WorkerThread <ActionThread>:
Unhandled exception in WorkerThread <EventThread>:

error: bad character range

User avatar
kgschlosser
Site Admin
Posts: 5498
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: erros when loading egtree made in stable version

Post by kgschlosser » Mon Feb 17, 2020 4:28 pm

I need you to zip up your save file and send it to me in a PM. I have removed the new user locks for your forum account so you will be able to send it without a problem.

This is the first time I have seen this error I am thinking it has to be with one of the events you have in your tree but I have to check to be sure and also to see what it is that is giving EG a problem.
If you like the work I have been doing then feel free to Image

Tiddu
Posts: 6
Joined: Sat Nov 30, 2019 7:04 am

Re: erros when loading egtree made in stable version

Post by Tiddu » Mon Feb 17, 2020 6:34 pm

hey

really grateful for your help. I have somehow managed to make it work [good for atm atleast] by manually moving each script from old egtree to new via notepad++ . I found out what I was doing wrong was trying to copy from old egtree to new without first installing or adding plugins in the autostart folder.

have a great day sir

Post Reply