Turn on Monitor: doesn't

Found a bug in EventGhost? Report it here.
User avatar
kgschlosser
Site Admin
Posts: 3595
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Turn on Monitor: doesn't

Post by kgschlosser » Tue Jun 13, 2017 3:42 am

this has been added to the next Release Candidate. which should be available within the next couple of days.
If you like the work I have been doing then feel free to Image

Snowbird
Experienced User
Posts: 283
Joined: Fri Jul 03, 2009 10:04 am

Re: Turn on Monitor: doesn't

Post by Snowbird » Tue Jun 13, 2017 6:33 am

That's a great news, thanks for the follow up !

blaher
Experienced User
Posts: 481
Joined: Thu Nov 17, 2011 1:27 am

Re: Turn on Monitor: doesn't

Post by blaher » Thu Jun 15, 2017 5:29 am

kgschlosser wrote:@blaher

Give this fix a try. I have a sneaky suspicion that it might fix the issue you are having as well.
I tried the attached PowerBroadcastNotifier.py, but it still won't turn my monitor on. I've tried delaying before running the OSD message, sending a move mouse command, and I tried running nircmd.exe, which I use to turn the monitor off, but http://www.nirsoft.net/utils/nircmd.html says there's just a monitor off, not an 'on'.


To save attachments:
https://pastebin.com/mbmgDB5y

When I tried to use a sendkeys, it crashed EG:

https://pastebin.com/SEy7sjvs

User avatar
kgschlosser
Site Admin
Posts: 3595
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Turn on Monitor: doesn't

Post by kgschlosser » Thu Jun 15, 2017 2:57 pm

ok i have a question. or a couple of them actually. I want to make sure I am understanding this properly.


first off i want to make sure that you have your monitor in a standby mode and not powered off. this could be what is causing the issue and is how the monitor is designed. so in the questions below i am assuming that it is in standby


all of the below have to be tested 2 ways letting the computer power down the monitor like normal and also having EG power it down.

if you move your mouse manually does the monitor turn on?
if you click a mouse button does the monitor turn on?
if you press a key on your keyboard does the monitor turn on?

and explain there is no "on" in nircmd. can you provide a screen shot of this?

and I would also like you to create a new EG configuration tree. with a single macro for a python script with the following code in it. then run the script. this will turn the monitor off then back on 5 seconds later

Code: Select all

import threading

t = threading.Timer(5.0, eg.plugins.System.MonitorPowerOn)
eg.plugins.System.MonitorPowerOff()
t.start()
this next one will attempt to use Standby so replace the above code with the code below and test it again.

Code: Select all

import threading

t = threading.Timer(5.0, eg.plugins.System.MonitorPowerOn)
eg.plugins.System.MonitorStandby()
t.start()

let me know the results of both
If you like the work I have been doing then feel free to Image

blaher
Experienced User
Posts: 481
Joined: Thu Nov 17, 2011 1:27 am

Re: Turn on Monitor: doesn't

Post by blaher » Fri Jun 16, 2017 1:12 am

kgschlosser wrote: if you move your mouse manually does the monitor turn on?
yes
if you click a mouse button does the monitor turn on?
yes
if you press a key on your keyboard does the monitor turn on?
yes
and explain there is no "on" in nircmd. can you provide a screen shot of this?
There's a link above with the nircmd commands. I can only see a monitor off command, not a monitor on command. But I did try monitor on with no luck.
and I would also like you to create a new EG configuration tree. with a single macro for a python script with the following code in it. then run the script. this will turn the monitor off then back on 5 seconds later

Code: Select all

import threading

t = threading.Timer(5.0, eg.plugins.System.MonitorPowerOn)
eg.plugins.System.MonitorPowerOff()
t.start()
Monitor goes off, tries to come back on, but eventually reverts to the power saving mode.
this next one will attempt to use Standby so replace the above code with the code below and test it again.

Code: Select all

import threading

t = threading.Timer(5.0, eg.plugins.System.MonitorPowerOn)
eg.plugins.System.MonitorStandby()
t.start()

let me know the results of both
This one does nothing at all.

Thanks for looking.

User avatar
kgschlosser
Site Admin
Posts: 3595
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Turn on Monitor: doesn't

Post by kgschlosser » Fri Jun 16, 2017 3:43 am

does EG crash when you run the first?

I also want to check and make sure you are running this on a brand new Configuration tree as well. I want to make sure that nothing else could be interfering with it.

Best bet is have EG make a new tree. make the python script with the code below. save the tree. close EG and then reopen it. it should load up the save tree again. Sometime there may be an issue with a plugin fully shutting down and I want to make sure there are no latent threads or anything like that kicking around.

and try this script. i bumped the timer up to 10 seconds. so it will wait that long before turning it back on.

Code: Select all

import threading

t = threading.Timer(10.0, eg.plugins.System.MonitorPowerOn)
eg.plugins.System.MonitorPowerOff()
t.start()

If you like the work I have been doing then feel free to Image

User avatar
kgschlosser
Site Admin
Posts: 3595
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Turn on Monitor: doesn't

Post by kgschlosser » Fri Jun 16, 2017 3:49 am

there is also someone else with a similar issue. what is the brand and model of your video card and also what is the driver version. I want to check and see if it could be some kind of an incompatibility between how EG is making the call and the hardware
If you like the work I have been doing then feel free to Image

blaher
Experienced User
Posts: 481
Joined: Thu Nov 17, 2011 1:27 am

Re: Turn on Monitor: doesn't

Post by blaher » Fri Jun 16, 2017 4:18 am

kgschlosser wrote:does EG crash when you run the first?
No, it's fine.
I also want to check and make sure you are running this on a brand new Configuration tree as well. I want to make sure that nothing else could be interfering with it.

Best bet is have EG make a new tree. make the python script with the code below. save the tree. close EG and then reopen it. it should load up the save tree again. Sometime there may be an issue with a plugin fully shutting down and I want to make sure there are no latent threads or anything like that kicking around.
OK, I didn't try restarting EG.
and try this script. i bumped the timer up to 10 seconds. so it will wait that long before turning it back on.

Code: Select all

import threading

t = threading.Timer(10.0, eg.plugins.System.MonitorPowerOn)
eg.plugins.System.MonitorPowerOff()
t.start()

It doesn't come back on, but now it gives an error, and crashes EG:

Code: Select all

14:15:03   14:15:03: 0 MainThread: PluginManager.ScanAllPlugins :0.3491376060849578
14:15:03   14:15:03: 0 MainThread: SendKeysParser.__init__()
14:15:03   14:15:03: 0 MainThread: Document.ShowFrame()
14:15:04   14:15:04: 0 MainThread: Document.ShowFrame => None
14:15:04   ---> Welcome to EventGhost <---
14:15:05   14:15:05: 1 MainThread: Start(cls=<class eg.Classes.CheckUpdate.CheckUpdate at 0x04AC86C0>)
14:15:05   14:15:05: 0 EventThread: EventThread.StartSession(filename=None)
14:15:05   14:15:05: 0 ActionThread: ActionThread.StartSession(filename=None)
14:15:05   14:15:05: 0 Thread-1: SessionChangeNotifier.Register()
14:15:05   14:15:05: 0 MouseThread: MouseThread.run()
14:15:05   14:15:05: 0 ActionThread: Document.Load(filePath=None)
14:15:05   14:15:05: 0 ActionThread: Document.LoadEmpty()
14:15:05   14:15:05: 1 MainThread: OSDFrame.__init__(parent=None)
14:15:05   14:15:05: 0 ActionThread: StartLoad(cls=<class 'eg.Classes.TreeLink.TreeLink'>)
14:15:05   14:15:05: 0 ActionThread: XML loaded in 0.007539 seconds.
14:15:05   14:15:05: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1835576, uMsg=536L, wParam=32787L, lParam=6732928)
14:15:05   14:15:05: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1835576, uMsg=536L, wParam=32787L, lParam=6733280)
14:15:05   14:15:05: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1835576, uMsg=536L, wParam=32787L, lParam=6732768)
14:15:05   14:15:05: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1835576, uMsg=536L, wParam=32787L, lParam=6678536)
14:15:05   14:15:05: 1 MainThread: TreeCtrl.OnItemCollapsingEvent(event=<wx.TreeEvent>)
14:15:05   Autostart
14:15:05   14:15:05: 0 ActionThread: ActionThread.StartSession => None
14:15:05   System.PowerProfile.PowerSaver
14:15:05   Main.OnInit
14:15:05   System.PowerSaving.Off
14:15:05   System.PowerSource.Line
14:15:05   System.Monitor.On
14:15:12   14:15:12: 1 MainThread: MainFrame.OnToolBarLeftDown(event=<wx.MouseEvent>)
14:15:12   14:15:12: 1 MainThread: MainFrame.OnToolBarLeftUp(event=<wx.MouseEvent>)
14:15:12   14:15:12: 1 MainThread: Document.ShowFrame()
14:15:12   14:15:12: 1 MainThread: MainFrame.Iconize(flag=False)
14:15:12   14:15:12: 1 MainThread: Document.ShowFrame => None
14:15:12   14:15:12: 1 MainThread: Document.CheckFileNeedsSave()
14:15:12   14:15:12: 1 MainThread: Document.CheckFileNeedsSave => 5100
14:15:16   14:15:16: 0 EventThread: EventThread.StopSession()
14:15:16   14:15:16: 0 ActionThread: ActionThread.StopSession()
14:15:16   14:15:16: 0 ActionThread: UnloadPlugins()
14:15:16   14:15:16: 0 ActionThread: closing C:\Program Files (x86)\EventGhost\plugins\EventGhost
14:15:16   14:15:16: 0 ActionThread: closing C:\Program Files (x86)\EventGhost\plugins\System
14:15:16   14:15:16: 0 ActionThread: System.__stop__()
14:15:16   14:15:16: 0 ActionThread: System.__stop__ => None
14:15:16   14:15:16: 0 ActionThread: closing C:\Program Files (x86)\EventGhost\plugins\Window
14:15:16   14:15:16: 0 ActionThread: closing C:\Program Files (x86)\EventGhost\plugins\Mouse
14:15:16   14:15:16: 0 ActionThread: Mouse.__stop__()
14:15:16   14:15:16: 0 ActionThread: Mouse.__close__()
14:15:16   14:15:16: 0 EventThread: StopSession done
14:15:16   14:15:16: 0 EventThread: EventThread.StartSession(filename=u'G:\\install programs\\nircmd\\nircmd-x64\\temp.egtree')
14:15:16   14:15:16: 0 ActionThread: ActionThread.StartSession(filename=u'G:\\install programs\\nircmd\\nircmd-x64\\temp.egtree')
14:15:16   14:15:16: 0 MouseThread: MouseThread.run => None
14:15:16   14:15:16: 0 ActionThread: Document.Load(filePath=u'G:\\install programs\\nircmd\\nircmd-x64\\temp.egtree')
14:15:16   14:15:16: 0 MouseThread: MouseThread.run()
14:15:16   14:15:16: 0 Thread-4: SessionChangeNotifier.Register()
14:15:16   14:15:16: 1 MainThread: OSDFrame.__init__(parent=None)
14:15:16   14:15:16: 0 ActionThread: StartLoad(cls=<class 'eg.Classes.TreeLink.TreeLink'>)
14:15:16   14:15:16: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1835576, uMsg=536L, wParam=32787L, lParam=171029528)
14:15:16   14:15:16: 0 ActionThread: XML loaded in 0.045016 seconds.
14:15:16   14:15:16: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1835576, uMsg=536L, wParam=32787L, lParam=171303000)
14:15:16   14:15:16: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1835576, uMsg=536L, wParam=32787L, lParam=171303064)
14:15:16   14:15:16: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1835576, uMsg=536L, wParam=32787L, lParam=177792688)
14:15:16   14:15:16: 1 MainThread: TreeCtrl.OnItemCollapsingEvent(event=<wx.TreeEvent>)
14:15:16   Autostart
14:15:16   14:15:16: 0 ActionThread: ActionThread.StartSession => None
14:15:16   System.PowerProfile.PowerSaver
14:15:16   Main.OnInit
14:15:17   System.PowerSaving.Off
14:15:17   System.PowerSource.Line
14:15:17   System.Monitor.On
14:15:22   14:15:22: 1 MainThread: TreeCtrl.OnLeftDoubleClickEvent(event=<wx.MouseEvent>)
14:15:22   14:15:22: 1 MainThread: TreeCtrl.OnLeftDoubleClickEvent => None
14:15:22   14:15:22: 1 MainThread: TreeCtrl.OnItemActivateEvent(event=<wx.TreeEvent>)
14:15:22   14:15:22: 2 MainThread: Configure.Do(item=<eg.Classes.Document.ActionItem object at 0x083D5E50>)
14:15:22   14:15:22: 2 MainThread: Create(cls=<class 'eg.Classes.ConfigDialog.ConfigDialog'>)
14:15:22   14:15:22: 3 MainThread: ConfigDialog.ProcessingTask()
14:15:22   14:15:22: 3 MainThread: ConfigDialog.Configure(treeItem=<eg.Classes.Document.ActionItem object at 0x083D5E50>)
14:15:22   14:15:22: 3 MainThread: ConfigDialog.__init__(style=536877632)
14:15:22   14:15:22: 3 MainThread: ConfigDialog.__init__ => None
14:15:22   14:15:22: 3 MainThread: ConfigDialog.FinishSetup()
14:15:22   14:15:22: 3 MainThread: ConfigDialog.Affirmed()
14:15:22   14:15:22: 2 MainThread: Create => <eg.Classes.ConfigDialog.ConfigDialog; proxy of <Swig Object of type 'wxDialog *' at 0x48fcc20> >
14:15:22   14:15:22: 2 MainThread: ConfigDialog.GetEvent()
14:15:22   14:15:22: 4 MainThread: Configure.Do(item=<eg.Classes.Document.ActionItem object at 0x083D5E50>)
14:15:22   14:15:22: 4 MainThread: Configure.Do => False
14:15:38   14:15:38: 1 MainThread: ConfigDialog.OnOK(event=<wx.CommandEvent>)
14:15:38   14:15:38: 1 MainThread: ConfigDialog.DispatchEvent(event=<wx.CommandEvent>, eventId=5100)
14:15:38   14:15:38: 3 MainThread: ConfigDialog.Affirmed => 5100
14:15:38   14:15:38: 3 MainThread: ConfigDialog.SetResult()
14:15:38   14:15:38: 2 MainThread: ConfigDialog.GetEvent => (5100, (u'import threading\n\nt = threading.Timer(15.0, eg.plugins.System.MonitorPowerOn)\neg.plugins.System.MonitorPowerOff()\nt.start()',))
14:15:38   14:15:38: 2 MainThread: ConfigDialog.GetEvent()
14:15:38   14:15:38: 3 MainThread: ConfigDialog.SetResult => None
14:15:38   14:15:38: 3 MainThread: ConfigDialog.Affirmed()
14:15:38   14:15:38: 3 MainThread: ConfigDialog.Affirmed => None
14:15:38   14:15:38: 3 MainThread: ConfigDialog.Configure => None
14:15:38   14:15:38: 3 MainThread: ConfigDialog.Destroy()
14:15:38   14:15:38: 3 MainThread: ConfigDialog.ProcessingTask => None
14:15:38   14:15:38: 2 MainThread: ConfigDialog.GetEvent => (None, None)
14:15:38   14:15:38: 2 MainThread: Configure.Do => True
14:15:38   14:15:38: 1 MainThread: ConfigDialog.DispatchEvent => None
14:15:38   14:15:38: 1 MainThread: ConfigDialog.OnOK => None
14:15:39   14:15:39: 1 MainThread: MainFrame.OnDialogDestroy(event=<wx.WindowDestroyEvent>)
14:15:42   Python Script
14:15:42      14:15:42: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1835576, uMsg=536L, wParam=32787L, lParam=171303416)
14:15:47      14:15:47: 0 MainMessageReceiver: timeout TriggerEventWait
14:15:47        File "threading.pyc", line 774, in __bootstrap
14:15:47        File "threading.pyc", line 801, in __bootstrap_inner
14:15:47        File "threading.pyc", line 754, in run
14:15:47        File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 280, in __MainLoop
14:15:47          self.__DoOneEvent()
14:15:47        File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 261, in __DoOneEvent
14:15:47          self.__PumpWaitingMessages()
14:15:47        File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 287, in __PumpWaitingMessages
14:15:47          while PeekMessage(byref(msg), 0, 0, 0, PM_REMOVE):
14:15:47        File "C:\Program Files (x86)\EventGhost\eg\Classes\MessageReceiver.py", line 127, in WindowProc
14:15:47          res = handler(hwnd, mesg, wParam, lParam)
14:15:47        File "C:\Program Files (x86)\EventGhost\eg\Utils.py", line 428, in LogItWrapper
14:15:47          return func(*args, **kwargs)
14:15:47        File "C:\Program Files (x86)\EventGhost\plugins\System\PowerBroadcastNotifier.py", line 254, in OnPowerBroadcast
14:15:47          source=self.plugin
14:15:47        File "C:\Program Files (x86)\EventGhost\eg\Classes\EventThread.py", line 151, in TriggerEventWait
14:15:47          traceback.print_stack()
14:15:47      
14:15:47      None
14:16:36      14:16:36: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1835576, uMsg=536L, wParam=32787L, lParam=171029144)
14:16:41      14:16:41: 0 MainMessageReceiver: timeout TriggerEventWait
14:16:41        File "threading.pyc", line 774, in __bootstrap
14:16:41        File "threading.pyc", line 801, in __bootstrap_inner
14:16:41        File "threading.pyc", line 754, in run
14:16:41        File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 280, in __MainLoop
14:16:41          self.__DoOneEvent()
14:16:41        File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 261, in __DoOneEvent
14:16:41          self.__PumpWaitingMessages()
14:16:41        File "C:\Program Files (x86)\EventGhost\eg\Classes\ThreadWorker.py", line 287, in __PumpWaitingMessages
14:16:41          while PeekMessage(byref(msg), 0, 0, 0, PM_REMOVE):
14:16:41        File "C:\Program Files (x86)\EventGhost\eg\Classes\MessageReceiver.py", line 127, in WindowProc
14:16:41          res = handler(hwnd, mesg, wParam, lParam)
14:16:41        File "C:\Program Files (x86)\EventGhost\eg\Utils.py", line 428, in LogItWrapper
14:16:41          return func(*args, **kwargs)
14:16:41        File "C:\Program Files (x86)\EventGhost\plugins\System\PowerBroadcastNotifier.py", line 254, in OnPowerBroadcast
14:16:41          source=self.plugin
14:16:41        File "C:\Program Files (x86)\EventGhost\eg\Classes\EventThread.py", line 151, in TriggerEventWait
14:16:41          traceback.print_stack()
14:16:41      
14:16:41      None

blaher
Experienced User
Posts: 481
Joined: Thu Nov 17, 2011 1:27 am

Re: Turn on Monitor: doesn't

Post by blaher » Fri Jun 16, 2017 4:29 am

kgschlosser wrote:there is also someone else with a similar issue. what is the brand and model of your video card and also what is the driver version. I want to check and see if it could be some kind of an incompatibility between how EG is making the call and the hardware

Asus GeForce GTX 1060 Strix Gaming OC 6GB Video Card

Code: Select all

NVIDIA System Information report created on: 06/16/2017 14:27:04
System name: BLAHER

[Display]
Operating System:	Windows 10 Enterprise, 64-bit
DirectX version:	12.0 
GPU processor:		GeForce GTX 1060 6GB
Driver version:		378.92
Direct3D API version:	12
Direct3D feature level:	12_1
CUDA Cores:		1280 
Core clock:		1569 MHz 
Memory data rate:	8008 MHz
Memory interface:	192-bit 
Memory bandwidth:	192.19 GB/s
Total available graphics memory:	14296 MB
Dedicated video memory:	6144 MB GDDR5
System video memory:	0 MB
Shared system memory:	8152 MB
Video BIOS version:	86.06.27.00.84
IRQ:			Not used
Bus:			PCI Express x16 Gen3
Device ID:		10DE 1C03 85C51043
Part Number:		G410 0030

[Components]

nvui.dll		8.17.13.7892		NVIDIA User Experience Driver Component
nvxdsync.exe		8.17.13.7892		NVIDIA User Experience Driver Component
nvxdplcy.dll		8.17.13.7892		NVIDIA User Experience Driver Component
nvxdbat.dll		8.17.13.7892		NVIDIA User Experience Driver Component
nvxdapix.dll		8.17.13.7892		NVIDIA User Experience Driver Component
NVCPL.DLL		8.17.13.7892		NVIDIA User Experience Driver Component
nvCplUIR.dll		8.1.960.0		NVIDIA Control Panel
nvCplUI.exe		8.1.960.0		NVIDIA Control Panel
nvWSSR.dll		6.14.13.7892		NVIDIA Workstation Server
nvWSS.dll		6.14.13.7892		NVIDIA Workstation Server
nvViTvSR.dll		6.14.13.7892		NVIDIA Video Server
nvViTvS.dll		6.14.13.7892		NVIDIA Video Server
nvLicensingS.dll		6.14.13.7892		NVIDIA Licensing Server
nvDispSR.dll		6.14.13.7892		NVIDIA Display Server
NVMCTRAY.DLL		8.17.13.7892		NVIDIA Media Center Library
nvDispS.dll		6.14.13.7892		NVIDIA Display Server
PhysX		09.16.0318		NVIDIA PhysX
NVCUDA.DLL		6.14.13.7892		NVIDIA CUDA 8.0.0 driver
nvGameSR.dll		6.14.13.7892		NVIDIA 3D Settings Server
nvGameS.dll		6.14.13.7892		NVIDIA 3D Settings Server

blaher
Experienced User
Posts: 481
Joined: Thu Nov 17, 2011 1:27 am

Re: Turn on Monitor: doesn't

Post by blaher » Fri Jun 16, 2017 4:54 am

I increased it to 15 secs, and my receiver locks onto the signal for a second and then disappears. EG doesn't crash anymore either after updating to the latest nvidia drivers.

Code: Select all

14:48:57   Python Script
14:48:57      Python Script
14:48:58   14:48:58: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1380022, uMsg=536L, wParam=32787L, lParam=6179808)
14:48:58   System.Monitor.Off
14:49:13   14:49:13: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1380022, uMsg=536L, wParam=32787L, lParam=6179296)
14:49:13   System.Monitor.On
14:49:14   14:49:14: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1380022, uMsg=536L, wParam=32787L, lParam=6179616)
14:49:14   System.Monitor.Off
14:49:41   14:49:41: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1380022, uMsg=536L, wParam=32787L, lParam=6179904)
14:49:41   System.Monitor.On

Code: Select all

NVIDIA System Information report created on: 06/16/2017 14:52:46
System name: BLAHER

[Display]
Operating System:	Windows 10 Enterprise, 64-bit
DirectX version:	12.0 
GPU processor:		GeForce GTX 1060 6GB
Driver version:		382.53
Direct3D API version:	12
Direct3D feature level:	12_1
CUDA Cores:		1280 
Core clock:		1569 MHz 
Memory data rate:	8008 MHz
Memory interface:	192-bit 
Memory bandwidth:	192.19 GB/s
Total available graphics memory:	14296 MB
Dedicated video memory:	6144 MB GDDR5
System video memory:	0 MB
Shared system memory:	8152 MB
Video BIOS version:	86.06.27.00.84
IRQ:			Not used
Bus:			PCI Express x16 Gen3
Device ID:		10DE 1C03 85C51043
Part Number:		G410 0030

[Components]

nvui.dll		8.17.13.8253		NVIDIA User Experience Driver Component
nvxdplcy.dll		8.17.13.8253		NVIDIA User Experience Driver Component
nvxdbat.dll		8.17.13.8253		NVIDIA User Experience Driver Component
nvxdapix.dll		8.17.13.8253		NVIDIA User Experience Driver Component
NVCPL.DLL		8.17.13.8253		NVIDIA User Experience Driver Component
nvCplUIR.dll		8.1.970.0		NVIDIA Control Panel
nvCplUI.exe		8.1.970.0		NVIDIA Control Panel
nvWSSR.dll		6.14.13.8253		NVIDIA Workstation Server
nvWSS.dll		6.14.13.8253		NVIDIA Workstation Server
nvViTvSR.dll		6.14.13.8253		NVIDIA Video Server
nvViTvS.dll		6.14.13.8253		NVIDIA Video Server
nvLicensingS.dll		6.14.13.8253		NVIDIA Licensing Server
nvDispSR.dll		6.14.13.8253		NVIDIA Display Server
NVMCTRAY.DLL		8.17.13.8253		NVIDIA Media Center Library
nvDispS.dll		6.14.13.8253		NVIDIA Display Server
PhysX		09.17.0329		NVIDIA PhysX
NVCUDA.DLL		6.14.13.8253		NVIDIA CUDA 8.0.0 driver
nvGameSR.dll		6.14.13.8253		NVIDIA 3D Settings Server
nvGameS.dll		6.14.13.8253		NVIDIA 3D Settings Server

User avatar
kgschlosser
Site Admin
Posts: 3595
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Turn on Monitor: doesn't

Post by kgschlosser » Fri Jun 16, 2017 6:51 am

so you are using an AVR to do video switching and the HDMI out on the card?

If that is the case you will probably have to keep on tinkering with the timer thread to get it right. because HDMI is 2 way communication if the Computer doesn't see a connection it's not going to output video and if the AVR doesn't see a connection it's not going to try and communicate with the video card.

so keep on increasing it and see if you can get the 2 to lock in. but i believe this is an issue between the AVR and the computer. have you tried using a direct connection with a monitor to see if has an issue there?


well at least we got the crashing thing solved. just have to find out what the next trip up is.

also do you have this issue if you turn the monitor off and then move the mouse to turn it back on?
If you like the work I have been doing then feel free to Image

User avatar
kgschlosser
Site Admin
Posts: 3595
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Turn on Monitor: doesn't

Post by kgschlosser » Thu Jun 22, 2017 7:24 pm

have ya made any headway with this?? I haven't given up on trying to get it sorted out.
If you like the work I have been doing then feel free to Image

blaher
Experienced User
Posts: 481
Joined: Thu Nov 17, 2011 1:27 am

Re: Turn on Monitor: doesn't

Post by blaher » Fri Jun 23, 2017 12:29 am

kgschlosser wrote:have ya made any headway with this?? I haven't given up on trying to get it sorted out.
Nah, no luck. It makes no difference if my AVR is on or not. It must just be an incompatibility with the power-saving feature of my Dell monitor, I'm guessing.

User avatar
kgschlosser
Site Admin
Posts: 3595
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Turn on Monitor: doesn't

Post by kgschlosser » Fri Jun 23, 2017 3:49 am

OK You will need to give me a layout of what is connected where.

as a couple of examples

Computer connected to the AVR as a video input and the Dell monitor is connected to the AVR output.
Computer connected to the AVR as a video input the AVR is connected to a TV and the PC is connected to the Dell monitor as well.

Have you tried only plugging the PC into 1 monitor and nothing else and see if it works that way?
If you like the work I have been doing then feel free to Image

blaher
Experienced User
Posts: 481
Joined: Thu Nov 17, 2011 1:27 am

Re: Turn on Monitor: doesn't

Post by blaher » Fri Jun 23, 2017 7:22 am

kgschlosser wrote:Computer connected to the AVR as a video input the AVR is connected to a TV and the PC is connected to the Dell monitor as well.
This
Have you tried only plugging the PC into 1 monitor and nothing else and see if it works that way?
No, and I can't at the moment, but I will when I have a chance.

Post Reply