Can't save config

If you have a question or need help, this is the place to be.
Post Reply
wysocki
Experienced User
Posts: 70
Joined: Mon Nov 23, 2015 9:23 pm
Location: Los Angeles area

Can't save config

Post by wysocki » Sun May 24, 2020 6:35 pm

My webserver stopped working and so in the process of checking out the config, I wanted to move the files that are the target of my Webserver plugin, so I changed the folder name then clicked on SAVE. That generated a bunch of errors in the log and the save was not committed. Also, there's some errors in the log about the log redirector and filter plugin. Possibly related? Here's the log:
Image 028.png

User avatar
kgschlosser
Site Admin
Posts: 5498
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Can't save config

Post by kgschlosser » Mon May 25, 2020 9:55 pm

you seem to not have a temp directory. Maybe your HDD is full?

open file explorer and type in %temp% in the address bar. see if it brings you to a location.

check that folder and see if there is a shit load of stuff in there.. make sure it is in facvt your temp directory and if it is delete everything in there if you want. this is good housekeeping anywho.

The serial error and the other error are joined at the hip. a serial port is actually a file that gets written to a read from it gets created in your temporary folder. as does the saving of EG and a bunch of other things do as well.
Your problem is in Windows not in EG.. I am thinking that you have a completely full HDD..
If you like the work I have been doing then feel free to Image

wysocki
Experienced User
Posts: 70
Joined: Mon Nov 23, 2015 9:23 pm
Location: Los Angeles area

Re: Can't save config

Post by wysocki » Sun Jun 07, 2020 10:54 pm

Although I have a D:\temp folder that I use for most junk, explorer shows %temp% as C:\Users\terry\AppData\Local\Temp which has 117mb of files in it. The C: drive is 232gb with 191 free. That temp folder DOES have like a thousand zero byte files named like mat-debug-99999.log in it??? So I deleted all the files there.

BUT, it does appear to have worked! I've restarted EG a few times with no errors and the %temp% folder now has a
C:\Users\terry\AppData\Local\Temp\comtypes_cache\EventGhost-27 folder in it (empty).

Puzzling, but thanks!

User avatar
kgschlosser
Site Admin
Posts: 5498
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Can't save config

Post by kgschlosser » Mon Jun 08, 2020 4:25 pm

EG does in fact write files to that folder. and there is a limit on the number of files that a folder can have. I do not remember what this limit is It could be simply that you needed to do some house cleaning is all. While programs are supposed to clean up themselves a lot of them do not and you can end up with a temp directory getting outta control.
If you like the work I have been doing then feel free to Image

Post Reply