Buttons going too fast

If you have a question or need help, this is the place to be.
Post Reply
Strahan
Posts: 1
Joined: Fri Jan 03, 2020 5:21 am

Buttons going too fast

Post by Strahan » Fri Jan 03, 2020 6:04 am

I was trying to make it so my remote control can control Amazon Video. I added a folder for Amazon, added a keyboard emulation macro to send "f". I added the USB-UIRT event and a find window to make it only work on Chrome windows with "Prime Video". It works, it triggers F when I hit the button, but it's like it's pressing it multiple times because the window goes full screen, then right back again. If I press F F on the keyboard, it does the exact same thing.

In Girder, it had a setting where you could add a delay between activation when an event fires to prevent the USB-UIRT signal from doing exactly this. In Girder I set a 200ms delay and it fixed it. Is there a way to do that in EG?

User avatar
kgschlosser
Site Admin
Posts: 5508
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Buttons going too fast

Post by kgschlosser » Fri Jan 10, 2020 3:47 am

OK so what is happening is you are probably getting a double event from the remote. I would need to see a screen shot of what EG looks like after the problem happens...

But this is what you would do.. at the end of your macro.. add the Wait action. set it to whatever you need to have it set to. Then add the Clear Pending Events action after the wait. This will clear out the event buffer, so if you did have a second event come in for a remote key press this is going to get rid of it..
If you like the work I have been doing then feel free to Image

Post Reply