EG on PC & Webcore

If you have a question or need help, this is the place to be.
Post Reply
trickyrick
Posts: 22
Joined: Mon Jul 16, 2018 4:32 pm

EG on PC & Webcore

Post by trickyrick » Wed Nov 14, 2018 9:05 pm

I have a couple pistons in webcore that start an event in EG they have being working for several months. I went on vacation for 6 weeks and now when I turn on my PC with EG the pistons no longer control the events. How do I trouble shoot. I havent changed any settings. One piston monitors power on a power outlet connected to a dryer. When the dryers power drops it triggers an event in EG. I see noting in EG
Rick

holdestmade
Experienced User
Posts: 183
Joined: Thu Dec 04, 2014 2:44 pm

Re: EG on PC & Webcore

Post by holdestmade » Thu Nov 15, 2018 9:09 am

How do you send events to EG from webcore ?

trickyrick
Posts: 22
Joined: Mon Jul 16, 2018 4:32 pm

Re: EG on PC & Webcore

Post by trickyrick » Thu Nov 15, 2018 3:43 pm

I use Smartthings

User avatar
yokel22
Experienced User
Posts: 265
Joined: Thu Feb 05, 2015 5:56 pm
Location: U.S. - Kansas city

Re: EG on PC & Webcore

Post by yokel22 » Thu Nov 15, 2018 4:46 pm

Correct me if im wrong here, but doesn't comm from smartThings to EG use the webserver/tcpip plugin?

holdestmade
Experienced User
Posts: 183
Joined: Thu Dec 04, 2014 2:44 pm

Re: EG on PC & Webcore

Post by holdestmade » Thu Nov 15, 2018 5:21 pm

Yes, I use smartthings and the EG plugin using EG's webserver, was just wondering how you used webcore directly with EG or do you just use the EG plugin to send events to EG from smartthings ?

trickyrick
Posts: 22
Joined: Mon Jul 16, 2018 4:32 pm

Re: EG on PC & Webcore

Post by trickyrick » Thu Nov 15, 2018 7:54 pm

I have EventGhost installed in Smartthings as a SmartApp. I have that setup with the ip address of my networked computer with por 80 and Command prefix of ST. I have set up EG Plugin webserver like the attached
It was working
Image
Attachments
Untitled.jpg

holdestmade
Experienced User
Posts: 183
Joined: Thu Dec 04, 2014 2:44 pm

Re: EG on PC & Webcore

Post by holdestmade » Thu Nov 15, 2018 9:23 pm

Not that it helps but mine is working fine. Has the IP of the computer changed or have you set it static ?

trickyrick
Posts: 22
Joined: Mon Jul 16, 2018 4:32 pm

Re: EG on PC & Webcore

Post by trickyrick » Fri Nov 16, 2018 4:14 am

The computer has a static IP

holdestmade
Experienced User
Posts: 183
Joined: Thu Dec 04, 2014 2:44 pm

Re: EG on PC & Webcore

Post by holdestmade » Fri Nov 16, 2018 9:39 am

Mine wouldn't work without a blank index.html file and the path setup in the EG webserver HTML documents root folder pointing to it.


index.html:

<head>
<title>EventGhost Webserver</title>
</head>
<body>
</body>

trickyrick
Posts: 22
Joined: Mon Jul 16, 2018 4:32 pm

Re: EG on PC & Webcore

Post by trickyrick » Fri Nov 16, 2018 2:32 pm

I dont know y but after I uninstalled and then reinstalled then used a back up to restore it works now

slattynan
Experienced User
Posts: 63
Joined: Fri Jul 06, 2018 12:15 pm

Re: EG on PC & Webcore

Post by slattynan » Fri Nov 16, 2018 5:54 pm

Did you turn your smartthings hub off while you were away?

I had to turn the power off in the house last week and had similar issues after... Still not found the root cause

trickyrick
Posts: 22
Joined: Mon Jul 16, 2018 4:32 pm

Re: EG on PC & Webcore

Post by trickyrick » Sat Nov 17, 2018 9:09 pm

Nope I was using it while away. I did have the computer off with EG. When I came back I turned the computer on and changed the IP from Dynamic to Static and reserved the IP on the router but that souldnt have caused any problem its the same IP

User avatar
yokel22
Experienced User
Posts: 265
Joined: Thu Feb 05, 2015 5:56 pm
Location: U.S. - Kansas city

Re: EG on PC & Webcore

Post by yokel22 » Sat Nov 17, 2018 9:35 pm

Im pretty sure it was some sort of network issue. The host just wasn't receiving messsages for whatever reason. Glad it got resolved.

Post Reply