New version 0.5.0-rc6 is out

Keep up to date with EG related information here.
User avatar
kgschlosser
Site Admin
Posts: 5508
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: New version 0.5.0-rc6 is out

Post by kgschlosser » Thu Mar 05, 2020 5:28 am

sem;colon

I am in agreement with this. topic has been on hiatus. I do not know where he is, and I have not been able to contact him. I have sent messager to cfull as well (he is the one that set up the github account). I do not have any permissions on the github repo for EG. So we have been sitting here. It is actully annoying me quite a bit. The only thing I am able to do is to create a new repository and go from there. Maybe if someone else tries to contact either one of those people they may have better luck. There are several fixes that I have coded up and that need to get added but I am not able to.
If you like the work I have been doing then feel free to Image

molitar
Experienced User
Posts: 214
Joined: Fri Sep 11, 2009 6:44 am

Re: New version 0.5.0-rc6 is out

Post by molitar » Fri Sep 11, 2020 10:43 pm

Is this still the latest version at this time? The reason I am asking is on my Ryzen 2700x Processor Eventghost uses high CPU usage on a single core out of the 16 cores. I am talking in the process of 80-95% cpu usage on a single core.. Which single core varies every time I start EventGhost but it is always a single core.

User avatar
kgschlosser
Site Admin
Posts: 5508
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: New version 0.5.0-rc6 is out

Post by kgschlosser » Sat Sep 12, 2020 2:48 am

start EventGhost and then make a new save file. Save the empty file then close and restart EventGhost and see if the high CPU use is still there. I am pretty sure it will be gone.

If it is gone then load you original save file. one at a time disable each plugin restarting EventGhost after you disable one of them and checking to see if the CPU use has gone down. If it has then you know what plugin is causing it. Report back to me your findings so I can correct the plugin.
If you like the work I have been doing then feel free to Image

User avatar
Sem;colon
Plugin Developer
Posts: 887
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: New version 0.5.0-rc6 is out

Post by Sem;colon » Wed Dec 02, 2020 2:59 pm

What's the status of EG 0.5 final?
It's almost two years since RC 6 was released, it's about time ;)
If you like my work, Image me a drink :wink:

abuttino
Experienced User
Posts: 148
Joined: Sun Jun 02, 2013 4:01 am

Re: New version 0.5.0-rc6 is out

Post by abuttino » Wed Dec 09, 2020 9:39 pm

Is this the release that is supposed to be compatible with Windows 10?

I have yet to have any luck with it running on 10. No matter what (changed ownerships, several workarounds also tried) it doesn't like my 0.4.1 configuration and usually have to copy the old eg folder into Windows 10.

That means, no plugins, and that means, I can't upgrade without starting fresh.

Any solid advice out there? I really would like to use my MCE/iR for my Harmony to do cool stuff on but, if I have to start over again, most of my macros will be dead in the water unless I recode a good percentage of it

In essence, there are two questions here..

Why doesn't this work with Windows 10? Administrator Run or not, it doesn't like my xml save location, won't pull it back up the next time I run EG.

What should I do about my config file? Loading it just gives all kinds of Python errors, even with the proper plugins in place.

User avatar
Sem;colon
Plugin Developer
Posts: 887
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: New version 0.5.0-rc6 is out

Post by Sem;colon » Fri May 14, 2021 9:32 pm

Hi Everyone!
As you may know the latest release (rc6) has some pretty annoying flaws.
What you may not know is, that most of the issues have been addressed and fixed in the meantime!
The fixes have been pulled into the master branch on github and will be part of the next release (which no one knows when this will happen)
I recently tried to build an installer with the actual state of development so you guys can test it. But I have to admit that I failed on doing this ^^°
So I thought I'll just provide you the improvements in form of a patch!
here's how it works:
-make sure eg is closed
-download the zip attached and extract it's content over the folder where eg 0.5 rc6 is installed
-replace or overwrite files if asked

Let me know if you still have any issues after the patch is applied :)
Attachments
EventGhost05rc6patch.zip
patch 1
(4.8 MiB) Downloaded 155 times
If you like my work, Image me a drink :wink:

yardern
Posts: 5
Joined: Sat May 29, 2021 1:38 pm

Re: New version 0.5.0-rc6 is out

Post by yardern » Sun May 30, 2021 2:20 am

Thanks for the Patch. :D
It still freezes quite often after applying the patch though.
Hope there will another patch please.
Below is what I got after restart:

---> Welcome to EventGhost <---
Traceback (most recent call last) (0.5.0-rc6):
File "wx\_core.pyc", line 16766, in <lambda>
File "C:\Program Files (x86)\EventGhost\eg\Classes\App.py", line 74, in DoOnClose
self.Yield()
File "wx\_core.pyc", line 7916, in Yield
PyAssertionError: C++ assertion "Assert failure" failed at ..\..\src\common\evtloopcmn.cpp(110) in wxEventLoopBase::Yield(): wxYield called recursively
Traceback (most recent call last) (0.5.0-rc6):
File "wx\_core.pyc", line 16766, in <lambda>
File "C:\Program Files (x86)\EventGhost\eg\Classes\App.py", line 74, in DoOnClose
self.Yield()
File "wx\_core.pyc", line 7916, in Yield
PyAssertionError: C++ assertion "Assert failure" failed at ..\..\src\common\evtloopcmn.cpp(110) in wxEventLoopBase::Yield(): wxYield called recursively

User avatar
Sem;colon
Plugin Developer
Posts: 887
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: New version 0.5.0-rc6 is out

Post by Sem;colon » Sun May 30, 2021 8:00 am

Hmm, could be related to your configuration - can you retry it with an empty config?
If you like my work, Image me a drink :wink:

yardern
Posts: 5
Joined: Sat May 29, 2021 1:38 pm

Re: New version 0.5.0-rc6 is out

Post by yardern » Mon May 31, 2021 12:37 am

Sem;colon wrote:
Sun May 30, 2021 8:00 am
Hmm, could be related to your configuration - can you retry it with an empty config?
Hi Sem;colon,

Thanks for your quick response.
Appreciated for looking in to this.
I deleted everything, left only an empty Autostart, then I got this:

DEBUG: 0 MainThread: PluginManager.ScanAllPlugins :0.2948202
DEBUG: 0 MainThread: SendKeysParser.__init__()
DEBUG: 0 MainThread: Document.ShowFrame()
DEBUG: 0 MainThread: Document.ShowFrame => None
---> Welcome to EventGhost <---
DEBUG: 0 Socket Server: starting...
DEBUG: 0 Socket Server: started.
DEBUG: 0 EventThread: EventThread.StartSession(filename=u'c:\\data\\empty.egtree')
DEBUG: 0 ActionThread: ActionThread.StartSession(filename=u'c:\\data\\empty.egtree')
DEBUG: 0 MouseThread: MouseThread.run()
DEBUG: 0 ActionThread: Document.Load(filePath=u'c:\\data\\empty.egtree')
DEBUG: 1 MainThread: OSDFrame.__init__(parent=None)
DEBUG: 0 ActionThread: StartLoad(cls=<class 'eg.Classes.TreeLink.TreeLink'>)
DEBUG: 0 ActionThread: Document.SetExpandState(expanded=set([0]))
DEBUG: 0 ActionThread: XML loaded in 0.007536 seconds.
DEBUG: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1903192, uMsg=536L, wParam=32787L, lParam=6792552)
DEBUG: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1903192, uMsg=536L, wParam=32787L, lParam=6792648)
DEBUG: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1903192, uMsg=536L, wParam=32787L, lParam=6792744)
DEBUG: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1903192, uMsg=536L, wParam=32787L, lParam=6879704)
DEBUG: 0 MainMessageReceiver: PowerBroadcastNotifier.OnPowerBroadcast(hwnd=1903192, uMsg=536L, wParam=32787L, lParam=6792872)
DEBUG: 0 Thread-3: SessionChangeNotifier.Register()
DEBUG: 1 MainThread: TreeCtrl.OnItemCollapsingEvent(event=<wx.TreeEvent>)
Windows.User.ping.chen {'IsLocalAdmin': False, 'IsDomainLogin': False}
EventGhost.Startup Sunday, May 30th, 2021 @ 20:35:00 PM
Autostart
DEBUG: 0 ActionThread: ActionThread.StartSession => None
System.PowerSaving.Off
Main.OnInit
System.PowerProfile.Balanced
System.BatteryLevel.100%
System.PowerSource.Line
System.Monitor.On

User avatar
Sem;colon
Plugin Developer
Posts: 887
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: New version 0.5.0-rc6 is out

Post by Sem;colon » Mon May 31, 2021 9:14 am

Hi yardern,

Looks good now, the lines with "DEBUG" in the beginnen are just there because you selected "log debug info" in the view menu.
So I think there's something wrong with your configuration, probably something generates an endless loop.

Please create a new thread for your issue under general support ;)
If you like my work, Image me a drink :wink:

yardern
Posts: 5
Joined: Sat May 29, 2021 1:38 pm

Re: New version 0.5.0-rc6 is out

Post by yardern » Wed Jun 02, 2021 1:09 am

Thanks! :D
Turns out I cannot use "Run Command" action for powershell, changed to "Run Application" solved the problem.

skribb
Experienced User
Posts: 231
Joined: Thu Feb 12, 2015 7:22 pm
Location: Win7 64bit

Re: New version 0.5.0-rc6 is out

Post by skribb » Sun Aug 08, 2021 10:52 am

Sem;colon wrote:
Fri May 14, 2021 9:32 pm
Hi Everyone!
As you may know the latest release (rc6) has some pretty annoying flaws.
What you may not know is, that most of the issues have been addressed and fixed in the meantime!
The fixes have been pulled into the master branch on github and will be part of the next release (which no one knows when this will happen)
I recently tried to build an installer with the actual state of development so you guys can test it. But I have to admit that I failed on doing this ^^°
So I thought I'll just provide you the improvements in form of a patch!
here's how it works:
-make sure eg is closed
-download the zip attached and extract it's content over the folder where eg 0.5 rc6 is installed
-replace or overwrite files if asked

Let me know if you still have any issues after the patch is applied :)


haha cool, i'm still running WIP-2019.03.10-20.11.47 , and i will stick with it until it borks out on me completely :lol: :lol: :lol: :lol:
Automation is life.

Windows: 7 64bit
EG: WIP-2019.03.10-20.11.47

Post Reply