Running from Source

Do you have questions about writing plugins or scripts in Python? Meet the coders here.
jsonnabend
Experienced User
Posts: 127
Joined: Wed Apr 23, 2008 7:35 pm

Re: Running from Source

Post by jsonnabend » Sun Jun 14, 2009 12:25 am

Brett, thanks for posting that. I have not been able to get ERIC running with EG, but I think I have both regular and stackless python installed. When I have a free moment (maybe next weekend), I'll try uninstalling regular python, then installing stackless and then ERIC again. If I can get EG running in an IDE, I'll contribute to development.

- Jeff
Last edited by jsonnabend on Sun Jun 14, 2009 2:13 pm, edited 1 time in total.

sparhawk
Posts: 31
Joined: Tue Jun 02, 2009 9:30 am

Re: Running from Source

Post by sparhawk » Sun Jun 14, 2009 7:31 am

So on my development machine I was now able to run EG form source. Thanks! :D

I get a error that ctypeslib is not installed, but apparently EG still works. Is this a problem? what do I need that for?

The minimum that I installed to run it was:
python-2.6.2-stackless.msi
pywin32-213.win32-py2.6.exe
wxPython2.8-win32-ansi-2.8.10.1-py26.exe
PIL-1.1.6.win32-py2.6.exe
docutils-0.5.tar.gz
comtypes-0.6.0.win32.exe

I had to uninstall the original python first in order to install the stackless version.

Additionally I also installed py2exe-0.6.9.win32-py2.6.exe but it's not needed right now. Maybe I see if I can create a working version that runs on my machine. I wonder that nobody else had this problem on W2k.
Last edited by sparhawk on Sun Jun 14, 2009 8:39 pm, edited 1 time in total.

jsonnabend
Experienced User
Posts: 127
Joined: Wed Apr 23, 2008 7:35 pm

Re: Running from Source

Post by jsonnabend » Sun Jun 14, 2009 2:13 pm

What are you using to edit and to debug? Anything at this point, or just a text editor?

- Jeff

sparhawk
Posts: 31
Joined: Tue Jun 02, 2009 9:30 am

Re: Running from Source

Post by sparhawk » Sun Jun 14, 2009 6:43 pm

I'm using notepad on that machine, because it's not supposed to be a developer machine. On my coding machine I use xemacs.

Well, so far I managed to get it working. To some extent...

I reinstalled stackless python, win32 and all the other stuff. For some reason it didn't work the first time, but maybe it was because I first had to uninstall the original python and forgot to reinstall.

I get still an error that some ActiveXCtrl library isn't found and there seems to be a null pointer exception because of it. EG seems to be running fine, despite of it, only thing is that I can't save now, because I get some exceptions in the log. I didn't look what errors these were though, because I can configure EG on my other machine and then copy over the XML, so that's not really a problem anyway.

I you want I can still post that errors, maybe you know what is still missing. On my developer machine EG works fine, both with the installer and from source. Don't know why the one W2K machine is so screwed up because I installed even Windows from scratch, and on my wife's machine it works out of the box, with the same version of Windows. :shock:

sparhawk
Posts: 31
Joined: Tue Jun 02, 2009 9:30 am

Re: Running from Source

Post by sparhawk » Sun Jun 14, 2009 8:40 pm

Now I also found the last component, and updated it in the above list of files that I had to download. Saving now works also.

I would prefer it if it would work with the installer, but running it from source is also ok. :D

jsonnabend
Experienced User
Posts: 127
Joined: Wed Apr 23, 2008 7:35 pm

Re: Running from Source

Post by jsonnabend » Tue Jun 16, 2009 3:13 pm

Hey, thanks so much for that list of packages. Hopefully I'll have some time to uninstall everything (including ERIC) and reinstall based on your list. I'll report back if I get everything up and running in ERIC.

- Jeff

sparhawk
Posts: 31
Joined: Tue Jun 02, 2009 9:30 am

Re: Running from Source

Post by sparhawk » Wed Jun 17, 2009 10:32 am

I posted it because I figured others might also run into troubles. I hope that it contains everything. Problem is that there is a lot of experimenting, so it might happen that I overlooked something that I installed and forgot about. If you run into something like that, it would be apreciated if you add it here.

I haven't tested py2exe so far, because I don't really care about that. It works, which is fine enough for me. :p So it might be that there is stuff missing if you want to create an installable.

Bartman
Plugin Developer
Posts: 881
Joined: Sun Feb 12, 2006 9:03 am

Re: Running from Source

Post by Bartman » Wed Jul 29, 2009 10:23 pm

After I had it running about a year ago I'm now trying to do again.
I still get the "ctypeslib is not installed!" message.

Bartman
Plugin Developer
Posts: 881
Joined: Sun Feb 12, 2006 9:03 am

Re: Running from Source

Post by Bartman » Sat Aug 01, 2009 3:06 pm

I just got EG running with Eclipse and PyDev.

stottle
Plugin Developer
Posts: 636
Joined: Sun Apr 26, 2009 10:59 pm

Re: Running from Source

Post by stottle » Sat Aug 01, 2009 3:40 pm

What's the secret?

Brett

Bartman
Plugin Developer
Posts: 881
Joined: Sun Feb 12, 2006 9:03 am

Re: Running from Source

Post by Bartman » Sat Aug 01, 2009 3:42 pm

Once I got all the packages installed listed by sparhawk I could run it from the command line and there was absolutly no hassle setting up eclipse + pydev

Post Reply